Em resumo
- CVE-2026-88023 é uma vulnerabilidade ALTO (CVSS 8.3) que afeta mongodb/mongodb, php library (mongodb).
- Chance de exploração nos próximos 30 dias (EPSS): 0.33%, maior que 25.8% das vulnerabilidades.
- Correção: atualize para 1.24.5, 2.4.2, 1.21.5 ou posterior.
| Package | Affected versions | Patched versions |
|---|
| mongodb/mongodb Packagist | ≥ 1.1.0, < 1.24.5≥ 2.0.0, < 2.4.2
| 1.24.52.4.2
|
| php library | ≥ 1.1.0, < 1.21.5≥ 2.0.0, < 2.4.2
| 1.21.52.4.2
|
Description
Impact
Improper neutralization of special elements in data query logic in the GridFS component of the MongoDB PHP Library can cause a caller-supplied structured file identifier to be interpreted as a query condition rather than as a literal identifier. An authenticated user who can influence the identifier passed by an affected application may obtain stored file content beyond the intended target or cause all GridFS file chunks in the affected bucket to be removed, rendering stored file content unreadable. The affected rename operation may also rename a stored file other than the intended target.
Patches
Fixed in 1.21.5 and 2.4.2.
Workarounds
Validate GridFS IDs.
References
https://jira.mongodb.org/browse/PHPLIB-1929
NVD description
Improper neutralization of special elements in data query logic in the GridFS component of the MongoDB PHP Library can cause a caller-supplied structured file identifier to be interpreted as a query condition rather than as a literal identifier. An authenticated user who can influence the identifier passed by an affected application may obtain stored file content beyond the intended target or cause all GridFS file chunks in the affected bucket to be removed, rendering stored file content unreadable. The affected rename operation may also rename a stored file other than the intended target.
Mais vulnerabilidades de mongodb/mongodb
Ver tudo →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free