| Package | Affected versions | Patched versions |
|---|---|---|
| mqtt-packet | ≥ 4.0.0, < 4.0.5< 3.4.6 | 4.0.53.4.6 |
| mqtt-packet | ≥ 4.0.0, < 4.0.5< 3.4.6 | 4.0.53.4.6 |
Versions of mqtt-packet prior to 3.4.6, or 4.x prior to 4.0.5 are affected by a denial of service vulnerability wherein specific sequences of MQTT packets can crash the application.
Version 3.x: Update to version 3.4.6 or later. Version 4.x: Update to version 4.0.5 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free