要点
- CVE-2016-10537 是影响 backbone (backbone project), backbone 的中危 (CVSS 5.4)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.68%,高于 52.5% 的漏洞。
- 修复:升级到 0.5.0 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| backbone | ≤ 0.3.3
| No fix yet |
| backbone npm | ≥ 0.3.3, < 0.5.0
| 0.5.0
|
Description
Affected versions of backbone are vulnerable to cross-site scripting when users are allowed to supply input to the Model#Escape function, and the output is then written to the DOM.
The vulnerability occurs as a result of the regular expression used to encode metacharacters failing to take HTML Entities such as < into account.
Recommendation
Update to version 0.5.0 or later.
NVD description
backbone is a module that adds in structure to a JavaScript heavy application through key-value pairs and custom events connecting to your RESTful API through JSON There exists a potential Cross Site Scripting vulnerability in the `Model#Escape` function of backbone 0.3.3 and earlier, if a user is able to supply input. This is due to the regex that's replacing things to miss the conversion of things such as `<` to `<`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free