要点
- CVE-2016-10550 是影响 sequelize (sequelizejs), sequelize 的严重 (CVSS 9.8)漏洞。
- 未来 30 天内被利用的概率(EPSS):1.9%,高于 79.5% 的漏洞。
- 修复:升级到 3.17.0 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| sequelize | ≤ 3.16.0
| No fix yet |
| sequelize npm | < 3.17.0
| 3.17.0
|
Description
Affected versions of sequelize are vulnerable to SQL Injection in locations where user input is passed into the limit or order parameters of sequelize query calls, such as findOne or findAll.
Recommendation
Update to version 3.17.0 or later.
NVD description
sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS If user input goes into the `limit` or `order` parameters, a malicious user can put in their own SQL statements. This affects sequelize 3.16.0 and earlier.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free