要点
- CVE-2016-10551 是影响 waterline-sequel (balderdash), waterline-sequel 的严重 (CVSS 9.8)漏洞。
- 未来 30 天内被利用的概率(EPSS):1.8%,高于 78.2% 的漏洞。
- 修复:升级到 0.5.1 或更高版本。
Description
Affected versions of waterline-sequel are vulnerable to SQL injection in cases where user input is passed into the like, contains, startsWith, or endsWith methods.
Recommendation
Upgrade to at least version 0.5.1
NVD description
waterline-sequel is a module that helps generate SQL statements for Waterline apps Any user input that goes into Waterline's `like`, `contains`, `startsWith`, or `endsWith` will end up in waterline-sequel with the potential for malicious code. A malicious user can input their own SQL statements in waterline-sequel 0.50 that will get executed and have full access to the database.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free