要点
- CVE-2017-16015 是影响 forms (forms project), forms 的中危 (CVSS 6.1)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.83%,高于 57.9% 的漏洞。
- 修复:升级到 1.3.0 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| forms | < 1.3.0
| 1.3.0
|
| forms npm | < 1.3.0
| 1.3.0
|
Description
Affected versions of forms do not properly escape HTML in generated forms, which may result in cross-site scripting.
Recommendation
Update to version 1.3.0 or later.
NVD description
Forms is a library for easily creating HTML forms. Versions before 1.3.0 did not have proper html escaping. This means that if the application did not sanitize html on behalf of forms, use of forms may be vulnerable to cross site scripting
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free