要点
- CVE-2017-16023 是影响 decamelize (decamelize project), decamelize 的高危 (CVSS 7.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):1.4%,高于 73.2% 的漏洞。
- 修复:升级到 1.1.2 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| decamelize | = 1.1.0= 1.1.1
| No fix yet |
| decamelize npm | ≥ 1.1.0, < 1.1.2
| 1.1.2
|
Description
Affected versions of decamelize are susceptible to a denial of service vulnerability when user input is passed directly into decamelize.
Recommendation
Update to version 1.1.2 or later.
NVD description
Decamelize is used to convert a dash/dot/underscore/space separated string to camelCase. Decamelize 1.1.0 through 1.1.1 uses regular expressions to evaluate a string and takes unescaped separator values, which can be used to create a denial of service attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free