要点
- CVE-2017-16025 是影响 nes (hapijs), nes 的中危 (CVSS 5.9)漏洞。
- 未来 30 天内被利用的概率(EPSS):1.9%,高于 79.4% 的漏洞。
- 修复:升级到 6.4.1 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| nes | ≤ 6.4.0
| No fix yet |
| nes npm | < 6.4.1
| 6.4.1
|
Description
Affected versions of nes are vulnerable to denial of service when given an invalid cookie header, and websocket authentication is set to cookie. Submitting an invalid cookie on the websocket upgrade request will cause the node process to throw and exit.
Recommendation
Update to version 6.4.1 or later.
NVD description
Nes is a websocket extension library for hapi. Hapi is a webserver framework. Versions below and including 6.4.0 have a denial of service vulnerability via an invalid Cookie header. This is only present when websocket authentication is set to `cookie`. Submitting an invalid cookie on the websocket upgrade request will cause the node process to error out.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free