要点
- CVE-2017-16029 是影响 hostr (hostr project), hostr 的高危 (CVSS 7.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):1.8%,高于 78.6% 的漏洞。
- 修复:升级到 2.3.6 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| hostr | ≤ 2.3.5
| No fix yet |
| hostr npm | < 2.3.6
| 2.3.6
|
Description
Affected versions of hostr are vulnerable to directory traversal which allows attackers to read files outside the current directory by sending ../ in the url path for GET requests.
Recommendation
Upgrade to version 2.3.6 or later.
NVD description
hostr is a simple web server that serves up the contents of the current directory. There is a directory traversal vulnerability in hostr 2.3.5 and earlier that allows an attacker to read files outside the current directory by sending `../` in the url path for GET requests.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free