要点
- CVE-2017-16099 是影响 no-case (no-case project), no-case 的高危 (CVSS 7.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):1.6%,高于 75.4% 的漏洞。
- 修复:升级到 2.3.2 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| no-case | < 2.3.2
| 2.3.2
|
| no-case npm | < 2.3.2
| 2.3.2
|
Description
Affected versions of no-case are vulnerable to a regular expression denial of service when parsing untrusted user input.
Recommendation
Update to version 2.3.2 or later.
NVD description
The no-case module is vulnerable to regular expression denial of service. When malicious untrusted user input is passed into no-case it can block the event loop causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free