要点
- CVE-2017-16111 是影响 content (content project), content 的高危 (CVSS 7.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):1.1%,高于 65.9% 的漏洞。
- 修复:升级到 3.0.7 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| content | ≤ 3.0.5
| No fix yet |
| content npm | < 3.0.7
| 3.0.7
|
Description
Affected versions of content are vulnerable to a regular expression denial of service when parsing malicious Content-Type and Content-Disposition headers.
Recommendation
Update to version 3.0.6 or later.
NVD description
The content module is a module to parse HTTP Content-* headers. It is used by the hapijs framework to provide this functionality. The module is vulnerable to regular expression denial of service when passed a specifically crafted Content-Type or Content-Disposition header.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free