要点
- CVE-2017-16118 是影响 forwarded (forwarded project), forwarded 的高危 (CVSS 7.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):1.9%,高于 79.3% 的漏洞。
- 修复:升级到 0.1.2 或更高版本。
Description
Affected versions of forwarded are vulnerable to regular expression denial of service when parsing specially crafted user input.
Recommendation
Update to version 0.1.2 or later
NVD description
The forwarded module is used by the Express.js framework to handle the X-Forwarded-For header. It is vulnerable to a regular expression denial of service when it's passed specially crafted input to parse. This causes the event loop to be blocked causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free