| Package | Affected versions | Patched versions |
|---|---|---|
| rubyzip | < 1.2.2 | 1.2.2 |
| cloudforms | = 4.6 | |
| rubyzip | ≤ 1.2.1 |
rubyzip gem rubyzip version 1.2.1 and earlier contains a Directory Traversal vulnerability in Zip::File component that can result in write arbitrary files to the filesystem. This attack appear to be exploitable via If a site allows uploading of .zip files , an attacker can upload a malicious file that contains symlinks or files with absolute pathnames "../" to write arbitrary files to the filesystem..
This is similar to CVE-2017-5946 which was patched in 1.2.1 but the fix in that case was incomplete.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free