| Package | Affected versions | Patched versions |
|---|---|---|
| dom4j:dom4j | ≤ 1.6.1 | |
| org.dom4j:dom4j | ≥ 2.1.0, < 2.1.1< 2.0.3 | 2.1.12.0.3 |
| dom4j | ≥ 2.0.0, < 2.0.3≥ 2.1.0, < 2.1.1 | 2.0.32.1.1 |
| flexcube investor servicing | = 12.0.4= 12.1.0= 12.3.0= 12.4.0= 14.0.0 | |
| primavera p6 enterprise project portfolio management | ≥ 16.1.0.0, ≤ 16.2.20.1≥ 17.1.0.0, ≤ 17.12.17.1≥ 18.1.0.0, ≤ 18.8.19.0≥ 19.12.0.0, ≤ 19.12.6.0 | |
| rapid planning | = 12.1= 12.2 | |
| retail integration bus | = 15.0= 16.0 | |
| utilities framework | = 2.2.0= 4.2.0.2.0= 4.2.0.3.0= 4.4.0.0.0= 4.4.0.2≥ 4.3.0.2.0, ≤ 4.3.0.6.0 | |
| jboss enterprise application platform | = 6.0.0= 6.4.0= 7.1.0 | |
| satellite | = 6.6 | |
| satellite capsule | = 6.6 |
dom4j version prior to version 2.1.1 contains a CWE-91: XML Injection vulnerability in Class: Element. Methods: addElement, addAttribute that can result in an attacker tampering with XML documents through XML injection. This attack appear to be exploitable via an attacker specifying attributes or elements in the XML document. This vulnerability appears to have been fixed in 2.1.1 or later.
Note: This advisory applies to dom4j:dom4j version 1.x legacy artifacts. To resolve this a change to the latest version of org.dom4j:dom4j is recommended.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free