要点
- CVE-2018-25031 是影响 org.webjars:swagger-ui, swagger ui (smartbear), swagger-ui 的中危 (CVSS 4.3)漏洞。
- 未来 30 天内被利用的概率(EPSS):42.3%,高于 98.7% 的漏洞。
- 修复:升级到 4.1.3 或更高版本。
Description
Swagger UI before 4.1.3 could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions.
NVD description
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
org.webjars:swagger-ui 的其他漏洞
查看全部 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free