要点
- CVE-2018-3750 是影响 deep extend (deep extend project), deep-extend 的严重 (CVSS 9.8)漏洞。
- 未来 30 天内被利用的概率(EPSS):2.1%,高于 82.2% 的漏洞。
- 修复:升级到 0.5.1 或更高版本。
Description
Versions of deep-extend before 0.5.1 are vulnerable to prototype pollution.
Recommendation
Update to version 0.5.1 or later.
NVD description
The utilities function in all versions <= 0.5.0 of the deep-extend node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free