要点
- CVE-2020-17521 是影响 org.codehaus.groovy:groovy, org.codehaus.groovy:groovy-all, atlas (apache) 的中危 (CVSS 5.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):1.0%,高于 63.6% 的漏洞。
- 修复:升级到 2.4.21, 2.5.14, 3.0.7 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| org.codehaus.groovy:groovy Maven | ≥ 2.0.0, < 2.4.21≥ 2.5.0, < 2.5.14≥ 3.0.0, < 3.0.7
| 2.4.212.5.143.0.7
|
| org.codehaus.groovy:groovy-all Maven | ≥ 2.0.0, < 2.4.21≥ 2.5.0, < 2.5.14≥ 3.0.0, < 3.0.7
| 2.4.212.5.143.0.7
|
| atlas | = 2.1.0
| No fix yet |
| groovy | = 4.0.0≥ 2.0.0, ≤ 2.4.20≥ 2.5.0, ≤ 2.5.13≥ 3.0.0, ≤ 3.0.6
| No fix yet |
| agile engineering data management | = 6.2.1.0
| No fix yet |
| agile plm mcad connector | = 3.4= 3.6
| No fix yet |
| agile product lifecycle management | = 9.3.3= 9.3.6
| No fix yet |
| business process management suite | = 12.2.1.3.0= 12.2.1.4.0
| No fix yet |
| communications brm - elastic charging engine | = 11.3.0.9.0= 12.0.0.3
| No fix yet |
| communications diameter signaling router | = 8.4.0.0
| No fix yet |
| communications evolved communications application server | = 7.1
| No fix yet |
| communications services gatekeeper | = 6.0= 6.1= 7.0
| No fix yet |
| healthcare data repository | = 7.0.2
| No fix yet |
| hospitality opera 5 | = 5.6
| No fix yet |
| ilearning | = 6.2= 6.3
| No fix yet |
| insurance policy administration | ≥ 11.0, ≤ 11.3.1
| No fix yet |
| jd edwards enterpriseone orchestrator | = 9.2.6.0
| No fix yet |
| primavera gateway | ≥ 17.12.0, ≤ 17.12.10
| No fix yet |
| primavera unifier | = 16.1= 16.2= 18.8= 19.12= 20.12≥ 17.7, ≤ 17.12
| No fix yet |
| retail bulk data integration | = 15.0.3.0= 16.0.3.0
| No fix yet |
| retail merchandising system | = 16.0.3
| No fix yet |
| retail store inventory management | = 14.1.3.10= 15.0.3.5= 16.0.3.5
| No fix yet |
Description
Apache Groovy provides extension methods to aid with creating temporary directories. Prior to this fix, Groovy's implementation of those extension methods was using a now superseded Java JDK method call that is potentially not secure on some operating systems in some contexts. Users not using the extension methods mentioned in the advisory are not affected, but may wish to read the advisory for further details. Versions Affected: 2.0 to 2.4.20, 2.5.0 to 2.5.13, 3.0.0 to 3.0.6, and 4.0.0-alpha-1. Fixed in versions 2.4.21, 2.5.14, 3.0.7, 4.0.0-alpha-2.
NVD description
Apache Groovy provides extension methods to aid with creating temporary directories. Prior to this fix, Groovy's implementation of those extension methods was using a now superseded Java JDK method call that is potentially not secure on some operating systems in some contexts. Users not using the extension methods mentioned in the advisory are not affected, but may wish to read the advisory for further details. Versions Affected: 2.0 to 2.4.20, 2.5.0 to 2.5.13, 3.0.0 to 3.0.6, and 4.0.0-alpha-1. Fixed in versions 2.4.21, 2.5.14, 3.0.7, 4.0.0-alpha-2.
org.codehaus.groovy:groovy 的其他漏洞
查看全部 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free