| Package | Affected versions | Patched versions |
|---|---|---|
| org.springframework.cloud:spring-cloud-gateway | ≥ 2.2.0, < 2.2.10.RELEASE0.5≥ 3.0.0, < 3.0.5 | 2.2.10.RELEASE0.53.0.5 |
| spring cloud gateway | ≥ 3.0.0, < 3.0.5< 2.2.10 | 3.0.52.2.10 |
Applications using Spring Cloud Gateway are vulnerable to specifically crafted requests that could make an extra request on downstream services. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.5+, 2.2.x users should upgrade to 2.2.10.RELEASE or newer.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free