| Package | Affected versions | Patched versions |
|---|---|---|
| smarty/smarty | ≥ 4.0.0, < 4.0.2< 3.1.42 | 4.0.23.1.42 |
| smarty | ≥ 4.0.0, < 4.0.2< 3.1.42 | 4.0.23.1.42 |
Template authors could run arbitrary PHP code by crafting a malicious math string. If a math string is passed through as user provided data to the math function, external users could run arbitrary PHP code by crafting a malicious math string.
Please upgrade to 4.0.2 or 3.1.42 or higher.
See documentation on Math function.
If you have any questions or comments about this advisory please open an issue in the Smarty repo
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free