要点
- CVE-2021-32708 是影响 league/flysystem, flysystem (thephpleague) 的高危 (CVSS 8.1)漏洞。
- 未来 30 天内被利用的概率(EPSS):3.5%,高于 89.2% 的漏洞。
- 修复:升级到 2.1.1, 1.1.4 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| league/flysystem Packagist | ≥ 2.0.0, < 2.1.1< 1.1.4
| 2.1.11.1.4
|
| flysystem | ≥ 1.0.0, < 1.1.4≥ 2.0.0, < 2.1.1
| 1.1.42.1.1
|
Description
Impact
The whitespace normalisation using in 1.x and 2.x removes any unicode whitespace. Under certain specific conditions this could potentially allow a malicious user to execute code remotely.
The conditions:
- A user is allowed to supply the path or filename of an uploaded file.
- The supplied path or filename is not checked against unicode chars.
- The supplied pathname checked against an extension deny-list, not an allow-list.
- The supplied path or filename contains a unicode whitespace char in the extension.
- The uploaded file is stored in a directory that allows PHP code to be executed.
Given these conditions are met a user can upload and execute arbitrary code on the system under attack.
Patches
The unicode whitespace removal has been replaced with a rejection (exception).
The library has been patched in:
Workarounds
For 1.x users, upgrade to 1.1.4. For 2.x users, upgrade to 2.1.1.
NVD description
Flysystem is an open source file storage library for PHP. The whitespace normalisation using in 1.x and 2.x removes any unicode whitespace. Under certain specific conditions this could potentially allow a malicious user to execute code remotely. The conditions are: A user is allowed to supply the path or filename of an uploaded file, the supplied path or filename is not checked against unicode chars, the supplied pathname checked against an extension deny-list, not an allow-list, the supplied path or filename contains a unicode whitespace char in the extension, the uploaded file is stored in a directory that allows PHP code to be executed. Given these conditions are met a user can upload and execute arbitrary code on the system under attack. The unicode whitespace removal has been replaced with a rejection (exception). For 1.x users, upgrade to 1.1.4. For 2.x users, upgrade to 2.1.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free