| Package | Affected versions | Patched versions |
|---|---|---|
| application express | < 21.1.4 | 21.1.4 |
| prism | < 1.24.0 | 1.24.0 |
| prismjs | < 1.24.0 | 1.24.0 |
Some languages before 1.24.0 are vulnerable to Regular Expression Denial of Service (ReDoS).
When Prism is used to highlight untrusted (user-given) text, an attacker can craft a string that will take a very very long time to highlight. Do not use the following languages to highlight untrusted text.
Other languages are not affected and can be used to highlight untrusted text.
This problem has been fixed in Prism v1.24.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free