| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.ranger:ranger-hive-plugin | ≥ 2.0.0, < 2.4.0 | 2.4.0 |
| ranger | ≥ 2.0.0, ≤ 2.3.0 |
An Incorrect Permission Assignment for Critical Resource vulnerability was found in the Apache Ranger Hive Plugin. Any user with SELECT privilege on a database can alter the ownership of the table in Hive when Apache Ranger Hive Plugin is enabled This issue affects Apache Ranger Hive Plugin: from 2.0.0 through 2.3.0. Users are recommended to upgrade to version 2.4.0 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free