| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.storm:storm | ≥ 1.0.0, < 1.2.4≥ 2.1.0, < 2.1.1≥ 2.2.0, < 2.2.1 | 1.2.42.1.12.2.1 |
| storm | ≥ 1.0.0, < 1.2.4≥ 2.1.0, < 2.1.1≥ 2.2.0, < 2.2.1 | 1.2.42.1.12.2.1 |
An Unsafe Deserialization vulnerability exists in the worker services of the Apache Storm supervisor server allowing pre-auth Remote Code Execution (RCE). Apache Storm 2.2.x users should upgrade to version 2.2.1 or 2.3.0. Apache Storm 2.1.x users should upgrade to version 2.1.1. Apache Storm 1.x users should upgrade to version 1.2.4
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free