要点
- CVE-2022-21659 是影响 flask-appbuilder, flask-appbuilder (dpgaspar) 的中危 (CVSS 5.3)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.95%,高于 61.3% 的漏洞。
- 修复:升级到 3.4.2, 3.4.4 或更高版本。
Description
Impact
User enumeration in database authentication in Flask-AppBuilder < 3.4.4. Allows for a non authenticated user to enumerate existing accounts by timing the response time from the server when you are logging in.
Patches
Upgrade to 3.4.4
Workarounds
References
For more information
If you have any questions or comments about this advisory:
NVD description
Flask-AppBuilder is an application development framework, built on top of the Flask web framework. In affected versions there exists a user enumeration vulnerability. This vulnerability allows for a non authenticated user to enumerate existing accounts by timing the response time from the server when you are logging in. Users are advised to upgrade to version 3.4.4 as soon as possible. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free