| Package | Affected versions | Patched versions |
|---|---|---|
| cruddl | ≥ 1.1.0, < 2.7.0≥ 3.0.0, < 3.0.2 | 2.7.03.0.2 |
| cruddl | ≥ 1.1.0, < 2.7.0≥ 3.0.0, < 3.0.2 | 2.7.03.0.2 |
If a vunerable version of cruddl is used to generate a schema that uses @flexSearchFulltext, users of that schema may be able to inject arbitrary AQL queries that will be forwarded to and executed by ArangoDB.
Schemas that do not use @flexSearchFulltext are not affected.
The attacker needs to have READ permission to at least one root entity type that has @flexSearchFulltext enabled.
The issue has been fixed in version 3.0.2 and in version 2.7.0 of cruddl.
Users can temporarily remove @flexSearchFulltext from their schemas before they can update cruddl.
If you have any questions or comments about this advisory:
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free