| Package | Affected versions | Patched versions |
|---|---|---|
| metabase | ≥ 0.41.0, < 0.41.9≥ 0.42.0, < 0.42.6≥ 0.43.0, < 0.43.7≥ 0.44.0, < 0.44.5≥ 1.41.0, < 1.41.9≥ 1.42.0, < 1.42.6≥ 1.43.0, < 1.43.7≥ 1.44.0, < 1.44.5 | 0.41.90.42.60.43.70.44.51.41.91.42.61.43.71.44.5 |
Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9, H2 (Sample Database) could allow Remote Code Execution (RCE), which can be abused by users able to write SQL queries on H2 databases. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase no longer allows DDL statements in H2 native queries.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free