要点
- CVE-2022-39383 是影响 github.com/oam-dev/kubevela, kubevela (linuxfoundation) 的中危 (CVSS 6.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.42%,高于 36.7% 的漏洞。
- 修复:升级到 1.6.1, 1.6.2, 1.5.8, 1.5.9 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| github.com/oam-dev/kubevela Go | ≥ 1.6.0, < 1.6.1≥ 1.6.0-alpha.1, < 1.6.2< 1.5.8< 1.5.9
| 1.6.11.6.21.5.81.5.9
|
| kubevela | ≥ 1.6.0, < 1.6.2< 1.5.9
| 1.6.21.5.9
|
Description
Impact
Users using the VelaUX APIServer could be affected by this vulnerability.
When using Helm Chart as the component delivery method, the request address of the warehouse is not restricted, and there is a blind SSRF vulnerability.
This issue is patched in 1.5.9 and 1.6.2.
References
Fix by: #5000
For more information
If you have any questions or comments about this advisory:
NVD description
KubeVela is an open source application delivery platform. Users using the VelaUX APIServer could be affected by this vulnerability. When using Helm Chart as the component delivery method, the request address of the warehouse is not restricted, and there is a blind SSRF vulnerability. Users who're using v1.6, please update the v1.6.1. Users who're using v1.5, please update the v1.5.8. There are no known workarounds for this issue.
github.com/oam-dev/kubevela 的其他漏洞
查看全部 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free