要点
- CVE-2022-41878 是影响 parse-server (parseplatform), parse-server 的严重 (CVSS 9.8)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.95%,高于 61.3% 的漏洞。
- 修复:升级到 5.3.2, 4.10.19 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| parse-server | ≥ 5.0.0, < 5.3.2< 4.10.19
| 5.3.24.10.19
|
| parse-server npm | ≥ 5.0.0, < 5.3.2< 4.10.19
| 5.3.24.10.19
|
Description
Impact
Keywords that are specified in the Parse Server option requestKeywordDenylist can be injected via Cloud Code Webhooks or Triggers. This will result in the keyword being saved to the database, bypassing the requestKeywordDenylist option.
Patches
Improved keyword detection.
Workarounds
Configure your firewall to only allow trusted servers to make request to the Parse Server Cloud Code Webhooks API, or block the API completely if you are not using the feature.
Collaborators
Mikhail Shcherbakov, Cristian-Alexandru Staicu and Musard Balliu working with Trend Micro Zero Day Initiative
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 5.3.2 or 4.10.19, keywords that are specified in the Parse Server option `requestKeywordDenylist` can be injected via Cloud Code Webhooks or Triggers. This will result in the keyword being saved to the database, bypassing the `requestKeywordDenylist` option. This issue is fixed in versions 4.10.19, and 5.3.2. If upgrade is not possible, the following Workarounds may be applied: Configure your firewall to only allow trusted servers to make request to the Parse Server Cloud Code Webhooks API, or block the API completely if you are not using the feature.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free