要点
- CVE-2022-41932 是影响 org.xwiki.platform:xwiki-platform-oldcore, xwiki (xwiki) 的中危 (CVSS 5.3)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.56%,高于 46.8% 的漏洞。
- 修复:升级到 14.4.2, 14.6-rc-1, 13.10.8, 14.6 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| org.xwiki.platform:xwiki-platform-oldcore Maven | ≥ 14.0.0, < 14.4.2≥ 14.5.0, < 14.6-rc-1< 13.10.8
| 14.4.214.6-rc-113.10.8
|
| xwiki | = 14.4.3= 14.4.4≥ 14.0.0, < 14.4.2≥ 14.5.0, < 14.6< 13.10.8
| 14.4.214.613.10.8
|
Description
Impact
It's possible to make XWiki create many new schemas and fill them with tables just by using a crafted user identifier in the login form.
Patches
The problem has been patched in XWiki 13.10.8, 14.6RC1 and 14.4.2.
Workarounds
The only workarounds for this are:
- use an authenticator which does interpret the login as a reference to a document
- using a different database than PostgreSQL
- upgrade XWiki
References
https://jira.xwiki.org/browse/XWIKI-19886
For more information
If you have any questions or comments about this advisory:
NVD description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It's possible to make XWiki create many new schemas and fill them with tables just by using a crafted user identifier in the login form. This may lead to degraded database performance. The problem has been patched in XWiki 13.10.8, 14.6RC1 and 14.4.2. Users are advised to upgrade. There are no known workarounds for this issue.
org.xwiki.platform:xwiki-platform-oldcore 的其他漏洞
查看全部 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free