要点
- CVE-2022-46170 是影响 codeigniter4/framework, codeigniter (codeigniter) 的严重 (CVSS 9.8)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.91%,高于 60.1% 的漏洞。
- 修复:升级到 4.2.11 或更高版本。
Description
Impact
When an application uses (1) multiple session cookies (e.g., one for user pages and one for admin pages) and (2) a session handler is set to DatabaseHandler, MemcachedHandler, or RedisHandler, then if an attacker gets one session cookie (e.g., one for user pages), they may be able to access pages that require another session cookie (e.g., for admin pages).
Patches
Upgrade to version 4.2.11 or later.
Workarounds
- Use only one session cookie.
References
For more information
If you have any questions or comments about this advisory:
NVD description
CodeIgniter is a PHP full-stack web framework. When an application uses (1) multiple session cookies (e.g., one for user pages and one for admin pages) and (2) a session handler is set to `DatabaseHandler`, `MemcachedHandler`, or `RedisHandler`, then if an attacker gets one session cookie (e.g., one for user pages), they may be able to access pages that require another session cookie (e.g., for admin pages). This issue has been patched, please upgrade to version 4.2.11 or later. As a workaround, use only one session cookie.
codeigniter4/framework 的其他漏洞
查看全部 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free