| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.sling:org.apache.sling.jcr.base | < 3.1.12 | 3.1.12 |
| sling jcr base | ≥ 2.0.6, < 3.1.12 | 3.1.12 |
Apache Sling JCR Base < 3.1.12 has a critical injection vulnerability when running on old JDK versions (JDK 1.8.191 or earlier) through utility functions in RepositoryAccessor. The functions getRepository and getRepositoryFromURL allow an application to access data stored in a remote location via JDNI and RMI. Users of Apache Sling JCR Base are recommended to upgrade to Apache Sling JCR Base 3.1.12 or later, or to run on a more recent JDK.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free