| Package | Affected versions | Patched versions |
|---|---|---|
| opensips | ≥ 3.2.0, < 3.2.4< 3.1.7 | 3.2.43.1.7 |
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, when the function `append_hf` handles a SIP message with a malformed To header, a call to the function `abort()` is performed, resulting in a crash. This is due to the following check in `data_lump.c:399` in the function `anchor_lump`. An attacker abusing this vulnerability will crash OpenSIPS leading to Denial of Service. It affects configurations containing functions that make use of the affected code, such as the function `append_hf`. This issue has been fixed in versions 3.1.7 and 3.2.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free