要点
- CVE-2023-34110 是影响 flask-appbuilder, flask-appbuilder (flask-appbuilder project) 的低危 (CVSS 2.7)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.68%,高于 52.2% 的漏洞。
- 修复:升级到 4.3.2 或更高版本。
Description
Impact
An authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password.
Patches
Fixed on 4.3.2
NVD description
Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free