| Package | Affected versions | Patched versions |
|---|---|---|
| powershell universal | = 4.2.0≥ 3.0.0, < 3.10.2≥ 4.1.0, < 4.1.10 | 3.10.24.1.10 |
The API endpoints in Ironman PowerShell Universal 3.0.0 through 4.2.0 allow remote attackers to execute arbitrary commands via crafted HTTP requests if a param block is used, due to invalid sanitization of input strings. The fixed versions are 3.10.2, 4.1.10, and 4.2.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free