要点
- CVE-2024-24758 是影响 undici (nodejs), undici 的中危 (CVSS 4.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.77%,高于 55.5% 的漏洞。
- 修复:升级到 6.6.1, 5.28.3 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| undici | ≥ 6.0.0, < 6.6.1< 5.28.3
| 6.6.15.28.3
|
| undici npm | ≥ 6.0.0, < 6.6.1< 5.28.3
| 6.6.15.28.3
|
Description
Impact
Undici already cleared Authorization headers on cross-origin redirects, but did not clear Proxy-Authorization headers.
Patches
This is patched in v5.28.3 and v6.6.1
Workarounds
There are no known workarounds.
References
NVD description
Undici is an HTTP/1.1 client, written from scratch for Node.js. Undici already cleared Authorization headers on cross-origin redirects, but did not clear `Proxy-Authentication` headers. This issue has been patched in versions 5.28.3 and 6.6.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free