要点
- CVE-2024-2660 是影响 github.com/hashicorp/vault, vault (hashicorp) 的中危 (CVSS 6.8)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.30%,高于 23.1% 的漏洞。
- 修复:升级到 1.16.0, 1.14.11, 1.15.7 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | < 1.16.0
| 1.16.0
|
| vault | ≥ 1.14.0, < 1.14.11≥ 1.14.0, < 1.16.0≥ 1.15.0, < 1.15.7
| 1.14.111.16.01.15.7
|
Description
Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. Fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.
NVD description
Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. This vulnerability, CVE-2024-2660, affects Vault and Vault Enterprise 1.14.0 and above, and is fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.
github.com/hashicorp/vault 的其他漏洞
查看全部 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free