要点
- CVE-2024-27091 是影响 geonode, geonode (geosolutionsgroup) 的中危 (CVSS 6.1)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.38%,高于 32.0% 的漏洞。
- 修复:升级到 4.2.3 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| geonode PyPI | ≥ 3.2.1, < 4.2.3
| 4.2.3
|
| geonode | > 3.2.0, < 4.2.3
| 4.2.3
|
Description
An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed.
NVD description
GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed. This vulnerability is fixed in 4.2.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free