要点
- CVE-2024-29904 是影响 codeigniter4/framework, codeigniter (codeigniter) 的高危 (CVSS 7.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.77%,高于 55.7% 的漏洞。
- 修复:升级到 4.4.7 或更高版本。
Description
Impact
A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server.
Patches
Upgrade to v4.4.7 or later. See upgrading guide.
Workarounds
- Disabling Auto Routing prevents a known attack vector in the framework.
- Do not pass invalid values to the
lang() function or Language class.
References
NVD description
CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.
codeigniter4/framework 的其他漏洞
查看全部 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free