要点
- CVE-2024-34069 是影响 werkzeug, werkzeug (palletsprojects) 的高危 (CVSS 7.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):3.4%,高于 88.8% 的漏洞。
- 修复:升级到 3.0.3 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| werkzeug PyPI | < 3.0.3
| 3.0.3
|
| werkzeug | < 3.0.3
| 3.0.3
|
Description
The debugger in affected versions of Werkzeug can allow an attacker to execute code on a developer's machine under some circumstances. This requires the attacker to get the developer to interact with a domain and subdomain they control, and enter the debugger PIN, but if they are successful it allows access to the debugger even if it is only running on localhost. This also requires the attacker to guess a URL in the developer's application that will trigger the debugger.
NVD description
Werkzeug is a comprehensive WSGI web application library. The debugger in affected versions of Werkzeug can allow an attacker to execute code on a developer's machine under some circumstances. This requires the attacker to get the developer to interact with a domain and subdomain they control, and enter the debugger PIN, but if they are successful it allows access to the debugger even if it is only running on localhost. This also requires the attacker to guess a URL in the developer's application that will trigger the debugger. This vulnerability is fixed in 3.0.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free