要点
- CVE-2025-48371 是影响 github.com/openfga/openfga, helm charts (openfga), openfga (openfga) 的高危 (CVSS 8.8)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.50%,高于 43.0% 的漏洞。
- 修复:升级到 1.8.13, 0.2.32 或更高版本。
Description
Overview
OpenFGA v1.8.0 to v1.8.12 ( openfga-0.2.16 <= Helm chart <= openfga-0.2.31, v1.8.0 <= docker <= v.1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed.
Am I Affected?
If you are using OpenFGA v1.8.0 to v1.8.12, specifically under the following conditions, you are affected by this authorization bypass vulnerability:
Fix
Upgrade to v1.8.13. This upgrade is backwards compatible.
Acknowledgments
OpenFGA would like to thank @udyvish for discovering this vulnerability.
NVD description
OpenFGA is an authorization/permission engine. OpenFGA versions 1.8.0 through 1.8.12 (corresponding to Helm chart openfga-0.2.16 through openfga-0.2.30 and docker 1.8.0 through 1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users are affected under four specific conditions: First, calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset; second, there are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset; third, those contextual tuples’s user field is an userset; and finally, type bound public access tuples are not assigned to the relationship. Users should upgrade to version 1.8.13 to receive a patch. The upgrade is backwards compatible.
github.com/openfga/openfga 的其他漏洞
查看全部 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free