要点
- CVE-2025-54998 是影响 github.com/openbao/openbao, openbao (openbao) 的中危 (CVSS 5.3)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.23%,高于 14.3% 的漏洞。
- 修复:升级到 2.3.2, 0.0.0-20250807212521-c52795c1ef74 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| github.com/openbao/openbao Go | ≥ 0.1.0, < 2.3.2≥ 0.1.0< 0.0.0-20250807212521-c52795c1ef74
| 2.3.20.0.0-20250807212521-c52795c1ef74
|
| openbao | < 2.3.2
| 2.3.2
|
Description
Impact
Attackers could bypass the automatic user lockout mechanisms in the OpenBao Userpass or LDAP auth systems. This was caused by different aliasing between pre-flight and full login request user entity alias attributions.
Patches
OpenBao v2.3.2 will patch this issue.
Workarounds
Existing users may apply rate-limiting quotas on the authentication endpoints: https://openbao.org/api-docs/system/rate-limit-quotas/
References
This issue was disclosed to HashiCorp and is the OpenBao equivalent of the following tickets:
NVD description
OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 0.1.0 through 2.3.1, attackers could bypass the automatic user lockout mechanisms in the OpenBao Userpass or LDAP auth systems. This was caused by different aliasing between pre-flight and full login request user entity alias attributions. This is fixed in version 2.3.2. To work around this issue, existing users may apply rate-limiting quotas on the authentication endpoints:, see https://openbao.org/api-docs/system/rate-limit-quotas/.
github.com/openbao/openbao 的其他漏洞
查看全部 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free