要点
- CVE-2025-58068 是影响 eventlet, eventlet (eventlet) 的严重 (CVSS 9.1)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.42%,高于 36.3% 的漏洞。
- 修复:升级到 0.40.3 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| eventlet PyPI | < 0.40.3
| 0.40.3
|
| eventlet | < 0.40.3
| 0.40.3
|
Description
Impact
The Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections.
This vulnerability could enable attackers to:
- Bypass front-end security controls
- Launch targeted attacks against active site users
- Poison web caches
Patches
Problem has been patched in eventlet 0.40.3.
The patch just drops trailers. If a backend behind eventlet.wsgi proxy requires trailers, then this patch BREAKS your setup.
Workarounds
Do not use eventlet.wsgi facing untrusted clients.
References
NVD description
Eventlet is a concurrent networking library for Python. Prior to version 0.40.3, the Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to, bypass front-end security controls, launch targeted attacks against active site users, and poison web caches. This problem has been patched in Eventlet 0.40.3 by dropping trailers which is a breaking change if a backend behind eventlet.wsgi proxy requires trailers. A workaround involves not using eventlet.wsgi facing untrusted clients.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free