要点
- CVE-2025-59160 是影响 matrix-js-sdk 的低危 (CVSS 2.7)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.24%,高于 15.5% 的漏洞。
- 修复:升级到 38.2.0 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| matrix-js-sdk npm | < 38.2.0
| 38.2.0
|
Description
Impact
matrix-js-sdk before 38.2.0 has insufficient validation of room predecessor links in MatrixClient::getJoinedRooms, allowing a remote attacker to attempt to replace a tombstoned room with an unrelated attacker-supplied room.
Patches
The issue has been patched and users should upgrade to 38.2.0.
Workarounds
Avoid using MatrixClient::getJoinedRooms in favour of getRooms() and filtering upgraded rooms separately.
NVD description
Matrix JavaScript SDK is a Matrix Client-Server SDK for JavaScript and TypeScript. matrix-js-sdk before 38.2.0 has insufficient validation of room predecessor links in MatrixClient::getJoinedRooms, allowing a remote attacker to attempt to replace a tombstoned room with an unrelated attacker-supplied room. The issue has been patched and users should upgrade to 38.2.0. A workaround is to avoid using MatrixClient::getJoinedRooms in favor of getRooms() and filtering upgraded rooms separately.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free