要点
- CVE-2025-66024 是影响 org.xwiki.contrib.blog:application-blog-ui, blog application (xwiki) 的严重 (CVSS 9.0)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.44%,高于 38.1% 的漏洞。
- 修复:升级到 9.15.7 或更高版本。
Description
Impact
The Blog Application is vulnerable to Stored Cross-Site Scripting (XSS) via the Blog Post Title. The vulnerability arises because the post title is injected directly into the HTML <title> tag without proper escaping.
An attacker with permissions to create or edit blog posts can inject malicious JavaScript into the title field. This script will execute in the browser of any user (including administrators) who views the blog post. This leads to potential session hijacking or privilege escalation.
To reproduce:
- Log in as a user with rights to create blog posts.
- Create a new blog post.
- In the Title field, insert the following payload designed to break out of the title tag:
</title><script>alert('XSS in title blog')</script>
- Save (Publish) the post.
- View the post in the blog home page
Patches
The vulnerability has been patched in the blog application version 9.15.7 by adding missing escaping.
Workarounds
We're not aware of any workarounds.
References
Attribution
Łukasz Rybak reported this vulnerability.
NVD description
The XWiki blog application allows users of the XWiki platform to create and manage blog posts. Versions starting with 9.15 and prior to 9.15.7 are vulnerable to Stored Cross-Site Scripting (XSS) via the Blog Post Title. The vulnerability arises because the post title is injected directly into the HTML <title> tag without proper escaping. An attacker with permissions to create or edit blog posts can inject malicious JavaScript into the title field. This script will execute in the browser of any user (including administrators) who views the blog post. This leads to potential session hijacking or privilege escalation. The vulnerability has been patched in the blog application version 9.15.7 by adding missing escaping. No known workarounds are available.
org.xwiki.contrib.blog:application-blog-ui 的其他漏洞
查看全部 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free