| Package | Affected versions | Patched versions |
|---|---|---|
| payload | = 4.0.0≥ 3.0.0, < 3.90.0 | 3.90.0 |
| payload | ≥ 3.0.0, < 3.90.0≥ 4.0.0-canary.0, < 4.0.0-canary.34 | 3.90.04.0.0-canary.34 |
Under certain field configurations, Payload could include unintended values in the authentication token issued at login.
You are affected if:
Payload now restricts which field configuration options can influence the contents of the authentication token.
Users should upgrade payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
There is no complete workaround. Users should upgrade payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free