要点
- CVE-2026-27980 是影响 next.js (vercel), next 的高危 (CVSS 7.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.71%,高于 53.5% 的漏洞。
- 修复:升级到 16.1.7, 15.5.14 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 10.0.0, < 16.1.7
| 16.1.7
|
| next npm | ≥ 10.0.0, < 15.5.14≥ 16.0.0-beta.0, < 16.1.7
| 15.5.1416.1.7
|
Description
Summary
The default Next.js image optimization disk cache (/_next/image) did not have a configurable upper bound, allowing unbounded cache growth.
Impact
An attacker could generate many unique image-optimization variants and exhaust disk space, causing denial of service. Note that this does not impact platforms that have their own image optimization capabilities, such as Vercel.
Patches
Fixed by adding an LRU-backed disk cache with images.maximumDiskCacheSize, including eviction of least-recently-used entries when the limit is exceeded. Setting maximumDiskCacheSize: 0 disables disk caching.
Workarounds
If upgrade is not immediately possible:
- Periodically clean
.next/cache/images.
- Reduce variant cardinality (e.g., tighten values for
images.localPatterns, images.remotePatterns, and images.qualities)
NVD description
Next.js is a React framework for building full-stack web applications. Starting in version 10.0.0 and prior to version 16.1.7, the default Next.js image optimization disk cache (`/_next/image`) did not have a configurable upper bound, allowing unbounded cache growth. An attacker could generate many unique image-optimization variants and exhaust disk space, causing denial of service. This is fixed in version 16.1.7 by adding an LRU-backed disk cache with `images.maximumDiskCacheSize`, including eviction of least-recently-used entries when the limit is exceeded. Setting `maximumDiskCacheSize: 0` disables disk caching. If upgrading is not immediately possible, periodically clean `.next/cache/images` and/or reduce variant cardinality (e.g., tighten values for `images.localPatterns`, `images.remotePatterns`, and `images.qualities`).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free