要点
- CVE-2026-34052 是影响 jupyterhub-ltiauthenticator, lti jupyterhub authenticator (jupyter) 的中危 (CVSS 5.9)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.34%,高于 27.7% 的漏洞。
- 修复:升级到 1.6.3 或更高版本。
Description
Summary
The LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service.
Patches
- upgrade jupyterhub-litauthenticator to 1.6.3
NVD description
LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.
jupyterhub-ltiauthenticator 的其他漏洞
查看全部 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free