要点
- CVE-2026-40293 是影响 github.com/openfga/openfga, openfga (openfga) 的中危 (CVSS 6.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.29%,高于 21.2% 的漏洞。
- 修复:升级到 1.14.0 或更高版本。
Description
Description
When OpenFGA is configured to use preshared-key authentication with the built-in playground enabled, the local server includes the preshared API key in the HTML response of the /playground endpoint. The /playground endpoint is enabled by default and does not require authentication. It is intended for local development and debugging and is not designed to be exposed to production environments.
Am I Affected?
You are affected if you meet each of the following preconditions:
- You are running OpenFGA with --authn-method preshared, and
- The playground is enabled, and
- The playground endpoint is accessible beyond localhost or trusted networks.
Fix
Upgrade to OpenFGA v1.14.0, or disable the playground by running ./openfga run --playground-enabled=false.
NVD description
OpenFGA is an authorization/permission engine built for developers. In versions 0.1.4 through 1.13.1, when OpenFGA is configured to use preshared-key authentication with the built-in playground enabled, the local server includes the preshared API key in the HTML response of the /playground endpoint. The /playground endpoint is enabled by default and does not require authentication. It is intended for local development and debugging and is not designed to be exposed to production environments. Only those who run OpenFGA with `--authn-method` preshared, with the playground enabled, and with the playground endpoint accessible beyond localhost or trusted networks are vulnerable. To remediate the issue, users should upgrade to OpenFGA v1.14.0, or disable the playground by running `./openfga run --playground-enabled=false.`
github.com/openfga/openfga 的其他漏洞
查看全部 →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free