要点
- CVE-2026-41168 是影响 pypdf, pypdf (pypdf project) 的中危 (CVSS 5.3)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.30%,高于 22.4% 的漏洞。
- 修复:升级到 6.10.1 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.10.1
| 6.10.1
|
| pypdf | < 6.10.1
| 6.10.1
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with wrong large /Size values or object streams with wrong large /N values.
Patches
This has been fixed in pypdf==6.10.1.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3733.
NVD description
pypdf is a free and open-source pure-python PDF library. An attacker who uses a vulnerability present in versions prior to 6.10.1 can craft a PDF which leads to long runtimes. This requires cross-reference streams with wrong large `/Size` values or object streams with wrong large `/N` values. This has been fixed in pypdf 6.10.1. As a workaround, one may apply the changes from the patch manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free