要点
- CVE-2026-42308 是影响 pillow, pillow (python) 的中危 (CVSS 5.5)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.11%,高于 1.4% 的漏洞。
- 修复:升级到 12.2.0 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| pillow PyPI | < 12.2.0
| 12.2.0
|
| pillow | < 12.2.0
| 12.2.0
|
Description
If a font advances for each glyph by an exceeding large amount, when Pillow keeps track of the current position, it may lead to an integer overflow. This has been fixed.
NVD description
Pillow is a Python imaging library. Prior to version 12.2.0, if a font advances for each glyph by an exceeding large amount, when Pillow keeps track of the current position, it may lead to an integer overflow. This issue has been patched in version 12.2.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free